- Purple
- Guest WiFi: a complete guide
- गेस्ट WiFi वरील Connected but No Internet एररचे निवारण करणे
गेस्ट WiFi वरील Connected but No Internet एररचे निवारण करणे
तुम्ही गेस्ट WiFi वर अतिथींना "connected, no internet" का दिसते याचे निदान करू शकाल आणि नवीन हार्डवेअर न वापरता कॉन्फिगरेशन बदलून याचे कारण दुरुस्त करू शकाल. हे मार्गदर्शन DNS टाइमआउट्सला DHCP, वॉल्ड गार्डन आणि रेट-लिमिट त्रुटींपासून कसे वेगळे करायचे आणि नंतर तुम्ही आधीच वापरत असलेल्या ॲक्सेस पॉइंट्सवर जवळच एंटरप्राइझ DNS फिल्टर कसे तैनात करायचे ते दाखवते.
Video overview
हे मार्गदर्शक ऐका
पॉडकास्ट ट्रान्सक्रिप्ट पहा
आमच्या मुख्य मालिकेचा भाग: गेस्ट WiFi मार्गदर्शक →
- गेस्ट WiFi वर "कनेक्ट केलेले, इंटरनेट नाही" कसे दिसते?
- गेस्ट WiFi वर सहसा कनेक्ट केलेले परंतु इंटरनेट नाही या त्रुटी कशामुळे होतात?
- गर्दीच्या नेटवर्कवर DNS टाइमआउट्स
- इतर सामान्य कारणे
- तुमचे कोणते कारण आहे हे तुम्ही कसे शोधाल?
- तुमच्या सपोर्ट टीमद्वारे केल्या जाणाऱ्या तीन तपासण्या
- एन्टरप्राइज DNS फिल्टर बॉटलनेक कसा दुरुस्त करतो?
- ते कुठे ठेवायचे
- यश ठरवणारे दोन सेटिंग्ज
- तुम्ही प्रत्येक व्हेंडर आणि ऑपरेटिंग सिस्टमवर याचे निराकरण कसे करता?
- तुमच्या ॲक्सेस पॉइंट्स आणि कंट्रोलरवर
- अतिथीच्या डिव्हाइसवर
- प्रत्यक्ष कार्यप्रणालीची उदाहरणे
- नाश्त्याच्या वेळी 200 खोल्यांचे हॉटेल
- हाफ-टाईमच्या वेळी 30,000 क्षमतेचे स्टेडियम
- तुम्ही कनेक्ट केलेले असूनही इंटरनेट नसण्याच्या त्रुटी पुन्हा होण्यापासून कसे रोखू शकता?
- वारंवार विचारले जाणारे प्रश्न
- कनेक्ट केलेल्या परंतु इंटरनेट नसलेल्या त्रुटींचे निवारण करण्यासाठी आम्हाला नवीन ॲक्सेस पॉइंट्सची आवश्यकता आहे का?
- Purple आमच्याकडे आधीपासून असलेल्या हार्डवेअरसोबत कार्य करते का?
- एंटरप्राइझ DNS फिल्टर आमच्या गेस्ट WiFi चा वेग कमी करेल का?
- गेस्टना 8.8.8.8 सारखा सार्वजनिक रिझॉल्व्हर थेट का देऊ नये?
- आपण GDPR अंतर्गत DNS क्वेरी लॉग कसे हाताळावेत?
- हे तैनात करण्यासाठी (डिप्लॉयमेंट) किती प्रयत्न करावे लागतात?
- Passpoint किंवा OpenRoaming ही त्रुटी दूर करेल का?
Guest WiFi “Connected, No Internet” Root-Cause Diagnostic Tool
Select your venue deployment profile, active connection failure symptom, and wireless infrastructure vendor to calculate probe timeout risks, diagnose DNS/DHCP bottlenecks, and generate multi-vendor remediation steps.
Root-Cause Diagnostic Analysis: Captive portal login popup never appears on mobile devices
Severity: CriticalOS captive portal detection probe DNS queries exceed the 2-5 second timeout window due to upstream resolver latency or dropped UDP packets.
Devices display "Connected, No Internet" and automatically drop the connection or fail back to mobile cellular data.
Deploy a local enterprise DNS caching filter, allowlist probe domains, and ensure UDP port 53 is allowed pre-authentication.
Vendor Implementation Guide: Cisco Meraki (Meraki Dashboard)
- DNS Configuration & Resolver Tuning:Under Wireless > Configure > Access control > Addressing and traffic, set Client IP assignment to "External DHCP server" or "Bridge mode" with reliable public Anycast DNS (1.1.1.1, 8.8.8.8).
- DHCP Scope & Lease Duration:In Security & SD-WAN > Configure > Addressing & VLANs, decrease DHCP lease time on the Guest VLAN to 30 minutes to prevent scope starvation.
- Walled Garden Pre-Authentication Rules:Under Wireless > Access control > Walled garden, enable Walled garden and add: *.purple.ai and the portal hosts only. Leave the OS probe hosts (captive.apple.com, connectivitycheck.gstatic.com, msftconnecttest.com) out, or devices will think they are online.
# Meraki Dashboard Configuration:
# 1. Wireless > Configure > Access Control > Splash Page: "Sign-on splash page"
# 2. Walled Garden ranges: *.purple.ai, fonts.googleapis.com (not the OS probe hosts)
# 3. Client IP assignment: Bridge Mode (NAT mode restricts Layer 2 client isolation)Experiencing guest WiFi onboarding failures across your venue?
Purple works with Cisco Meraki, HPE Aruba, Ruckus, Juniper Mist, Ubiquiti UniFi, Cambium, Extreme and Fortinet, and manages the pre-auth walled garden and DNS allowances that most of these failures trace back to.
गेस्ट WiFi वरील "कनेक्ट केलेले पण इंटरनेट नाही" ही त्रुटी कॅप्टिव्ह पोर्टल लोड होण्यापूर्वी कनेक्टिव्हिटी तपासणी अयशस्वी झाल्यावर येते. गर्दीच्या ठिकाणी, गर्दीदरम्यान UDP पोर्ट 53 DNS क्वेरी (RFC 1035) टाइम आउट होतात. याचे निवारण करण्यासाठी गेस्ट DHCP स्कोप कॅशिंग DNS फिल्टरकडे निर्देशित करणे, Cisco Meraki सारख्या कंट्रोलर्सवर वॉल्ड गार्डन डोमेन्स पूर्ण करणे आणि ट्रॅफिक शेपिंग नियमांचे पुनरावलोकन करणे आवश्यक आहे.
गेस्ट WiFi वर "कनेक्ट केलेले, इंटरनेट नाही" कसे दिसते?
गेस्टला पूर्ण सिग्नल बार आणि नेटवर्क जोडलेले दिसते, परंतु काहीही लोड होत नाही. लॉगिन पृष्ठ कधीही दिसत नाही, त्यामुळे ते अटी स्वीकारू शकत नाहीत किंवा साइन इन करू शकत नाहीत. त्यानंतर ते फ्रंट डेस्क, हेल्प पॉइंट किंवा सर्व्हिस काउंटरकडे जातात.
प्रत्येक ऑपरेटिंग सिस्टम ही चेतावणी वेगवेगळ्या शब्दांत दाखवते. तुमच्या वेन्यू सपोर्ट टीमला या सर्व चेतावण्या ओळखता आल्या पाहिजेत:
- Windows नेटवर्क नावाच्या खाली "इंटरनेट नाही" दाखवते.
- Android "इंटरनेटशिवाय कनेक्ट केले आहे" किंवा "इंटरनेट उपलब्ध नसू शकते" दाखवते.
- iPhone आणि iPad नेटवर्क नावाच्या खाली "इंटरनेट कनेक्शन नाही" दाखवते.
तिन्ही चेतावण्या एकाच यंत्रणेतून येतात. जॉईन झाल्यानंतर, डिव्हाइस कनेक्शन तपासण्यासाठी एका ज्ञात वेब पत्त्याची विनंती करते. त्या चाचणीत अपेक्षित पृष्ठ परत आल्यास, डिव्हाइस कनेक्शन चालू असल्याचे मानते. जर ते लॉगिन पृष्ठ परत करत असेल, तर डिव्हाइस कॅप्टिव्ह पोर्टल उघडते. जर काहीही उत्तर मिळाले नाही, तर डिव्हाइस "इंटरनेट नाही" असा रिपोर्ट देते.
| ऑपरेटिंग सिस्टम | कनेक्टिव्हिटी-तपासणी होस्टनेम | अयशस्वी झाल्यावर गेस्टला काय दिसते |
|---|---|---|
| iOS, iPadOS, macOS | captive.apple.com | "इंटरनेट कनेक्शन नाही" |
| Android | connectivitycheck.gstatic.com | "इंटरनेटशिवाय कनेक्ट केले आहे" |
| Windows 10 आणि 11 | www.msftconnecttest.com | "इंटरनेट नाही" |
डिव्हाइस यापैकी कोणत्याही पृष्ठाची विनंती करण्यापूर्वी, त्याला DNS द्वारे होस्टनेम शोधावे लागते. तो शोध हीच बहुतांश हाय-डेन्सिटी त्रुटींची सुरुवात असते.
गेस्ट WiFi वर सहसा कनेक्ट केलेले परंतु इंटरनेट नाही या त्रुटी कशामुळे होतात?
गर्दीच्या नेटवर्कवर DNS टाइमआउट्स
DNS (डोमेन नेम सिस्टम) होस्टनेमचे IP पत्त्यामध्ये रूपांतर करते. RFC 1035 मध्ये परिभाषित केल्यानुसार, बहुतांश DNS क्वेरी UDP पोर्ट 53 वरून प्रवास करतात. UDP मध्ये इन-बिल्ट रीट्रांसमिशन नसते, त्यामुळे ड्रॉप झालेली क्वेरी फक्त डिव्हाइसच्या स्वतःच्या रीट्राई टायमरची वाट पाहते.
गर्दी एकाएकी वाढते. स्टेडियममधील हाफ-टाइम, हॉटेलमधील ब्रेकफास्ट चेक-आउट किंवा स्टेशनवर येणारी ट्रेन असा विचार करा. सेकंदांमध्ये शेकडो डिव्हाइसेस जॉईन होतात आणि प्रत्येक डिव्हाइस एकाच वेळी शोध विनंती पाठवते. रिझॉल्व्हर व्यस्त WAN लिंकवर अनेक हॉप्स दूर असल्यास, क्वेरींना विलंब होतो किंवा त्या ड्रॉप होतात. डिव्हाइस प्रयत्न सोडून देते, पोर्टल कधीही उघडत नाही आणि गेस्टला "इंटरनेट नाही" असे दिसते.
इतर सामान्य कारणे
गर्दीच्या ठिकाणी DNS हे सर्वात सामान्य कारण आहे, परंतु एकमेव नाही. खालील कारणांची देखील तपासणी करा:
- गहाळ वॉल्ड गार्डन नोंदी. वॉल्ड गार्डन ही लॉगिनपूर्वी डिव्हाइस पोहोचू शकणाऱ्या डोमेन्सची सूची आहे. तुमचे पोर्टल किंवा त्याची ॲसेट गहाळ असल्यास, पृष्ठ लोड होऊ शकत नाही.
- DHCP पूल संपणे. ॲड्रेस पूल संपल्यास, डिव्हाइसेस स्वतःला 169.254.x.x ॲड्रेस असाइन करतात आणि कशापर्यंतही पोहोचू शकत नाहीत.
- UDP port 53 वरील दर मर्यादा (Rate limits) किंवा QoS थ्रॉटलिंग. प्रति-क्लायंट किंवा प्रति-SSID मर्यादा खूप घट्ट सेट केल्यास रहदारीच्या वेळी DNS प्रतिसाद मिळणे कठीण होऊ शकते.
- एन्क्रिप्टेड DNS. DNS over HTTPS (DoH, RFC 8484) आणि DNS over TLS (DoT, RFC 7858) हे लूकअप्स बाहेरच्या सॉल्व्हर्सकडे पाठवतात. अशा सॉल्व्हर्सना ब्लॉक करणारे walled garden लॉग इन करण्यापूर्वीच लूकअप थांबवते.
- अपस्ट्रीम आऊटेज (आउटेज). जर WAN लिंक स्वतःच बंद असेल, तर प्रत्येक डिव्हाइस आणि प्रत्येक वायर असलेले पोर्ट देखील अपयशी ठरते.
तुमचे कोणते कारण आहे हे तुम्ही कसे शोधाल?
हार्डवेअरपासून नाही, तर पॅटर्नपासून सुरुवात करा. काहीही बदलण्यापूर्वी कारण शोधण्यासाठी ही मॅट्रिक्स वापरा.
| तुम्हाला काय दिसते | सर्वात संभाव्य कारण | पहिली कृती |
|---|---|---|
| भाकीत केलेल्या गर्दीच्या वेळी एरर वाढतात, शांत वेळेत ठीक असतात | गर्दीच्या वेळी DNS टाईमआउट्स | गेस्ट DHCP ला जवळच्या कॅशिंग DNS फिल्टरकडे पॉइंट करा |
| दिवसभर प्रत्येक डिव्हाइस अपयशी ठरते | अपस्ट्रीम WAN आऊटेज किंवा DHCP मध्ये चुकीचा DNS सर्व्हर | WAN लिंक आणि DHCP DNS सेटिंग तपासा |
| डिव्हाइस 169.254.x.x पत्ता दाखवते | DHCP पूल संपला आहे | पूल मोठा करा किंवा लीजची वेळ कमी करा |
| पोर्टल लोड होऊ लागते पण अडकते किंवा रिकामे पेज दाखवते | walled garden मध्ये पोर्टल डोमेन समाविष्ट नाहीत | तुमच्या Purple सेटअप लेखातील डोमेन जोडा |
| फक्त काही Android डिव्हाइसेस किंवा लॅपटॉप अपयशी ठरतात | डिव्हाइसवर खाजगी DNS, DoT किंवा DoH सेट आहे | गेस्टला प्रायव्हेट DNS स्वयंचलित वर स्विच करण्यास सांगा |
| प्रति AP डिव्हाइसेसच्या सेट केलेल्या संख्येच्या वरच अपयशी ठरते | UDP port 53 वर रेट लिमिट्स किंवा QoS | गेस्ट SSID ट्रॅफिक-शेपिंग नियमांचे पुनरावलोकन करा |
तुमच्या सपोर्ट टीमद्वारे केल्या जाणाऱ्या तीन तपासण्या
- डिव्हाइसचा IP पत्ता तपासा. 169.254.x.x पत्ता DNS नव्हे तर DHCP कडे निर्देश करतो. सामान्य गेस्ट-रेंज पत्त्याचा अर्थ असा आहे की डिव्हाइस योग्यरित्या जॉईन झाले आहे.
- चाचणी डिव्हाइसवरून लूकअपची वेळ मोजा. गेस्ट नेटवर्कवरील लॅपटॉपवरून
nslookup captive.apple.comचालवा. व्यस्त कालावधीत मंद किंवा अपयशी ठरलेले उत्तर DNS बॉटलनेकची पुष्टी करते. - गेस्ट VLAN वर पॅकेट्स कॅप्चर करा. एक VLAN (व्हर्च्युअल LAN) तुमच्या इतर नेटवर्कपासून गेस्ट ट्रॅफिक वेगळा करतो.
udp port 53वर कॅप्चर फिल्टर करा आणि जुळणारा प्रतिसाद नसलेल्या क्वेरी शोधा.
नंतर एरर कधी येतात ते तपासा. WiFi Analytics मध्ये, पाहुणे समस्या नोंदवतात त्या वेळेविरुद्ध कनेक्शन आणि लॉगिन प्रमाणाची तुलना करा. तुमच्या सर्वात व्यस्त तासांचा मागोवा घेणारे अपयश गर्दीकडे स्पष्टपणे निर्देश करतात.
एन्टरप्राइज DNS फिल्टर बॉटलनेक कसा दुरुस्त करतो?
एन्टरप्राइज DNS फिल्टर हे तुमच्या नियंत्रणातील रिझॉल्व्हर आहे, जे गेस्ट नेटवर्कच्या जवळ ठेवलेले असते. हे दूरच्या ISP किंवा सार्वजनिक रिझॉल्व्हरची जागा घेते जे आज DHCP द्वारे दिले जाते. हे तीन कामे करते जे टाईमआउट काढून टाकतात.
हे कॅशमधून उत्तर देते. व्यस्त ठिकाणी एका तासात हजारो वेळा कनेक्टिव्हिटी-चेक होस्टनेमची विनंती केली जाते. जवळचा फिल्टर त्याच्या कॅशमधून वारंवार होणाऱ्या लूकअप्सची उत्तरे देतो, त्यामुळे ते कधीही गर्दीच्या WAN लिंकवरून जात नाहीत.
हे अनधिकृत ट्रॅफिक लवकर काढून टाकते. त्रासदायक किंवा ब्लॉक केलेल्या श्रेणींसाठीच्या क्वेरी फिल्टरवरच नाकारल्या जातात. त्यामुळे महत्त्वाच्या लूकअप्ससाठी WAN क्षमता मोकळी होते.
हे प्रत्येक क्वेरीची नोंद ठेवते. कोणत्या डोमेन्स अयशस्वी झाल्या, कधी आणि किती वेळा, याची नोंद तुम्हाला मिळते. यामुळे पुढील वेळी जेव्हा मॅनेजर समस्येची तक्रार करतो, तेव्हा अंदाजांचे रूपांतर पुराव्यात होते.
ते कुठे ठेवायचे
वितरित इस्टेटसाठी, जसे की शेकडो लहान साइट्स असलेली रिटेल साखळी, जवळच्या एज स्थानांसह क्लाउडद्वारे दिलेले फिल्टर हा सहसा व्यावहारिक पर्याय असतो. स्टेडियम किंवा कॉन्फरन्स सेंटरसारख्या एकाच मोठ्या साइटसाठी, साइटवर होस्ट केलेले रिझॉल्व्हर लुकअप पूर्णपणे WAN बाहेर ठेवते. दोन्ही प्रकरणांमध्ये, DHCP मध्ये दोन रिझॉल्व्हर पत्ते द्या जेणेकरून एका अपयशामुळे नेटवर्क बंद पडणार नाही.
यश ठरवणारे दोन सेटिंग्ज
प्रथम, फिल्टरमध्ये तुमच्या Captive Portal डोमेन्सना अनुमती द्या. पोर्टलला ब्लॉक करणारे किंवा उशीर करणारे फिल्टर तुम्ही ज्या समस्येचे निराकरण करण्यासाठी निघाला आहात तीच त्रुटी पुन्हा निर्माण करते. दुसरे, अतिथी DNS कॉर्पोरेट DNS पासून वेगळे ठेवा. PCI DSS अतिथी नेटवर्कला तुमच्या कार्डधारक डेटा वातावरणाच्या कक्षेपासून बाहेर ठेवण्याचा मार्ग म्हणून नेटवर्क सेगमेंटेशन मानतो.
तुमच्या विशिष्ट सेटअपबद्दल काही प्रश्न आहेत का?
आमची टीम ८०,००० हून अधिक वेन्यूजमधील वेन्यू ऑपरेटर्स, IT मॅनेजर्स आणि नेटवर्क इंजिनिअर्ससोबत काम करते. २० मिनिटांचा कॉल बुक करा आणि तुमच्यासारख्या इतरांनी ही समस्या कशी सोडवली हे आम्ही तुम्हाला दाखवू.
तुम्ही प्रत्येक व्हेंडर आणि ऑपरेटिंग सिस्टमवर याचे निराकरण कसे करता?
तुमच्या ॲक्सेस पॉइंट्स आणि कंट्रोलरवर
Purple हे हार्डवेअर-अग्नोस्टिक आहे आणि Cisco Meraki, HPE Aruba, Ruckus, Juniper Mist, Ubiquiti UniFi, Cambium, Extreme आणि Fortinet वर क्लाउड ओव्हरले म्हणून चालते. यापैकी प्रत्येकावर त्याचे निराकरण समान तीन टप्प्यांचे अनुसरण करते:
- अतिथी DHCP कक्षेतील DNS सर्व्हर तुमच्या एंटरप्राइझ DNS फिल्टरवर अपडेट करा.
- Walled garden पूर्ण करा. Cisco Meraki, HPE Aruba आणि Ruckus सर्व "walled garden" ही संज्ञा वापरतात. तुमच्या व्हेंडरसाठी Purple सेटअप लेखाचे अनुसरण करा, ज्यामध्ये अनुमती देण्याच्या अचूक डोमेन्सची यादी आहे.
- अतिथी ट्रॅफिक शेपिंग तपासा जेणेकरून प्रति-क्लायंट मर्यादा गर्दीच्या वेळी UDP पोर्ट 53 थ्रॉटल करणार नाहीत.
व्हेंडर्समध्ये सेटिंग्ज कॉपी करू नका. मेनूची नावे आणि डिफॉल्ट्स भिन्न असतात, त्यामुळे Purple सेटअप लेखासोबत व्हेंडरचे स्वतःचे दस्तऐवज वापरा.
अतिथीच्या डिव्हाइसवर
जेव्हा एखादा अतिथी प्रभावित होतो आणि बाकी सर्व ठीक असतात, तेव्हा तुमची डेस्क टीम या पायऱ्या वापरून पाहू शकते:
- नेटवर्क विसरून जा (Forget the network) आणि पुन्हा सामील व्हा जेणेकरून नवीन कनेक्टिव्हिटी तपासणी सुरू होईल.
- साधा http:// पत्ता उघडा जेणेकरून ब्राऊझरमध्ये पोर्टल दिसण्यास भाग पाडले जाईल.
- Android वर, Private DNS स्वयंचलित (Automatic) वर सेट करा. निश्चित केलेला Private DNS प्रदाता लॉग इन करण्यापूर्वी लुकअप ब्लॉक करू शकतो.
- कोणतेही VPN ॲप थांबवा जोपर्यंत अतिथीने साइन इन केले नाही.
प्रत्यक्ष कार्यप्रणालीची उदाहरणे
खालील आकडेवारी स्पष्टीकरणासाठी आहे, नामांकित तैनातीवरून घेतलेली नाही. तुमच्या स्वतःच्या ठिकाणी काय मोजायचे यासाठी एक मॉडेल म्हणून त्यांचा वापर करा.
नाश्त्याच्या वेळी 200 खोल्यांचे हॉटेल
परिस्थिती. सकाळी 7 ते 9 दरम्यान "इंटरनेट नाही" अशा फ्रंट-डेस्क तक्रारी वाढतात, जेव्हा अतिथी चेकआउटपूर्वी ईमेल तपासतात. ॲक्सेस पॉइंट्स उत्तम सिग्नल आणि मोकळा एअरटाइम दाखवतात. अतिथी DHCP व्यस्त लाइनवरून अनेक हॉप्स असलेल्या ISP चा रिझॉल्व्हर प्रदान करतो.
काय करण्यात आले. IT मॅनेजरने गर्दीच्या वेळेत nslookup चालवले आणि पाहिले की लुकअप पूर्णपणे अयशस्वी होत आहेत. टीमने अतिथी DHCP ला क्लाउड DNS फिल्टरकडे निर्देशित केले, walled garden मध्ये पोर्टल डोमेन्स जोडले आणि अतिथी DNS ला प्रॉपर्टी मॅनेजमेंट नेटवर्कपासून वेगळे ठेवले.
परिणाम. WiFi ॲनालिटिक्स आणि डेस्क लॉगमध्ये मोजल्यानुसार, पीक अवर वेळेतील पोर्टल पूर्ण होण्याचे प्रमाण 81% वरून 97% पर्यंत वाढले. डेस्कवर येणाऱ्या WiFi तक्रारी दररोज सकाळी सुमारे 15 वरून दोनवर आल्या. हॉटेल गेस्ट नेटवर्कबद्दल अधिक माहितीसाठी, आमची हॉस्पिटॅलिटी पृष्ठे पहा.
हाफ-टाईमच्या वेळी 30,000 क्षमतेचे स्टेडियम
परिस्थिती. प्रत्येक हाफ-टाईमच्या वेळी चाहत्यांनी "इंटरनेटशिवाय कनेक्ट केले आहे" अशी तक्रार केली, तर प्रत्येक हाफचे पहिले दहा मिनिटे सुरळीत चालले. गेस्ट VLAN वर पॅकेट कॅप्चरने गर्दीच्या वेळी कोणतेही उत्तर नसलेल्या DNS क्वेरी दाखवल्या.
काय करण्यात आले. नेटवर्क आर्किटेक्टने क्लाउड फॉलबॅकसह ऑन-साइट रिझॉल्व्हर तैनात केला. टीमने प्रति-क्लायंट दर मर्यादा हटवली ज्याने UDP पोर्ट 53 थ्रॉटल केला होता आणि DHCP स्कोप नवीन रिझॉल्व्हरवर हलवला.
परिणाम. पाठपुरावा कॅप्चरमध्ये हाफ-टाईममधील अनुत्तरित DNS क्वेरी 12% वरून 1% पेक्षा कमी झाल्या. मागील सामन्याच्या तुलनेत या अंतरालात चाहत्यांच्या लॉगइनमध्ये 40% ने वाढ झाली.
तुम्ही कनेक्ट केलेले असूनही इंटरनेट नसण्याच्या त्रुटी पुन्हा होण्यापासून कसे रोखू शकता?
- केवळ दूरवरच्या सार्वजनिक रिझॉल्व्हरवर कधीही अवलंबून राहू नका. सार्वजनिक DNS सामान्यतः चांगले कार्य करते, परंतु काही हॉप्स दूर असलेला रिझॉल्व्हर गर्दीच्या वेळी विलंब वाढवतो ज्यावर तुमचे नियंत्रण नसते.
- अनुत्तरित DNS क्वेरींवर ॲलर्ट ठेवा. तुमच्या फायरवॉल किंवा कोर स्विचला गेस्ट नेटवर्कवरील वाढत्या UDP पोर्ट 53 ड्रॉप्स फ्लॅग करण्यासाठी कॉन्फिगर करा, जे पाहुण्यांच्या लक्षात येण्यापूर्वी टाइमआउटचे संकेत देतात.
- दरमहा DNS फिल्टर ब्लॉकलिस्टचे पुनरावलोकन करा. अत्यंत आक्रमक श्रेणी कायदेशीर ॲप्स खंडित करतात आणि नवीन सपोर्ट तिकीट तयार करतात.
- लॉग रिटेंशन कालावधी सेट करा. DNS लॉग आयपी पत्ते त्यांनी भेट दिलेल्या डोमेनशी जोडतात, म्हणून त्यांच्याशी GDPR अंतर्गत वैयक्तिक डेटा म्हणून व्यवहार करा.
- तुमचे हार्डवेअर जिथे सपोर्ट करते तिथे RFC 8910 स्वीकारा. हे DHCP ला कॅप्टिव्ह पोर्टल कुठे आहे ते डिव्हाइसला सांगू देते, ज्यामुळे डिव्हाइस कनेक्टिव्हिटी-चेक लुकअपवर कमी अवलंबून राहते.
- पुन्हा भेट देणाऱ्या अभ्यागतांसाठी Passpoint चा विचार करा. Passpoint (ज्याला Hotspot 2.0 देखील म्हणतात) आणि OpenRoaming डिव्हाइसेसना कॅप्टिव्ह पोर्टलशिवाय सुरक्षितपणे जॉईन होऊ देतात, जे त्यांच्यासाठी हा फेल्युअर मोड पूर्णपणे काढून टाकते.
Purple 90 हून अधिक देशांमधील 80,000+ लाईव्ह ठिकाणांवर, दरवर्षी 500 दशलक्ष वापरकर्ते आणि लॉगइनसह गेस्ट WiFi चालवते. हेल्थकेअर वेटिंग रूम्सपासून ते ट्रेन्स पर्यंत, पॅटर्न समान राहतो: बँडविड्थ खरेदी करण्यापूर्वी DNS चे निवारण करा.
वारंवार विचारले जाणारे प्रश्न
कनेक्ट केलेल्या परंतु इंटरनेट नसलेल्या त्रुटींचे निवारण करण्यासाठी आम्हाला नवीन ॲक्सेस पॉइंट्सची आवश्यकता आहे का?
नाही, बहुतेक प्रकरणांमध्ये तुम्हाला गरज नसते. जेव्हा त्रुटी पीक वेळेत येते, तेव्हा याचे कारण सहसा DNS रिझोल्यूशन असते, ॲक्सेस पॉइंट हार्डवेअर नाही. याचे निवारण म्हणजे कॉन्फिगरेशन बदलणे: गेस्ट DHCP ला जवळच्या एंटरप्राइज DNS फिल्टरकडे निर्देश करा, वॉल्ड गार्डन पूर्ण करा आणि ट्रॅफिक-शेपिंग नियमांचे पुनरावलोकन करा. पॅकेट कॅप्चरने ॲक्सेस पॉइंट्स स्वतःच सामान्य लोडवर ट्रॅफिक ड्रॉप करत असल्याचे दाखवल्यानंतर आणि तुम्ही DHCP आणि DNS ला वगळल्यानंतरच हार्डवेअर बदला.
Purple आमच्याकडे आधीपासून असलेल्या हार्डवेअरसोबत कार्य करते का?
होय, Purple तुम्ही आधीपासून वापरत असलेल्या अॅक्सेस पॉईंट्सवर चालते. Purple हे हार्डवेअर-अॅग्नॉस्टिक आहे आणि Cisco Meraki, HPE Aruba, Ruckus, Juniper Mist, Ubiquiti UniFi, Cambium, Extreme आणि Fortinet वर क्लाउड ओव्हरले म्हणून तैनात केले जाते. यामध्ये कोणतेही जुने काढून नवीन बसवण्याची गरज नाही. Purple प्रत्येक व्हेंडरसाठी एक सेटअप लेख प्रकाशित करते, ज्यामध्ये पाहुण्यांनी (गेस्ट) साइन इन करण्यापूर्वी कॅप्टिव्ह पोर्टल लोड होण्यासाठी तुमच्या कंट्रोलरला आवश्यक असलेल्या वॉल गार्डन्स डोमेन्सची यादी दिलेली असते.
एंटरप्राइझ DNS फिल्टर आमच्या गेस्ट WiFi चा वेग कमी करेल का?
नाही, उत्तम प्रकारे सेट केलेले DNS फिल्टर साधारणपणे लुकअपचा वेग वाढवते. हे ISP किंवा सार्वजनिक रिझॉल्व्हरपेक्षा गेस्ट नेटवर्कच्या अधिक जवळ असते आणि त्याच्या कॅशेमधून वारंवार होणाऱ्या लुकअप्सना उत्तरे देते. धोका हा फिल्टरिंगमध्ये नसून त्याच्या जागा आणि कॉन्फिगरेशनमध्ये असतो. रिडंडन्सीसाठी दोन रिझॉल्व्हर पत्त्यांचे वाटप करा, आणि तुमच्या कॅप्टिव्ह पोर्टल डोमेन्सना अनुमती द्या जेणेकरून फिल्टरमुळे लॉगिन पेजला कधीही उशीर होणार नाही.
गेस्टना 8.8.8.8 सारखा सार्वजनिक रिझॉल्व्हर थेट का देऊ नये?
तुम्ही देऊ शकता, परंतु यामुळे गर्दीमुळे होणारा टाइमआउटचा प्रश्न सुटत नाही. सार्वजनिक रिझॉल्व्हर हा अजूनही तुमच्या WAN लिंकच्या पलीकडे असतो, त्यामुळे प्रत्येक लुकअप हा त्रुटीस कारणीभूत ठरणाऱ्या ट्रॅफिकच्या वाढीशी स्पर्धा करतो. हे तुम्हाला फिल्टरिंगची सुविधा आणि त्रुटी निवारणासाठी (ट्रबलशूटिंग) क्वेरी लॉग देखील देत नाही. जवळचे एंटरप्राइझ फिल्टर कॅशेमधून उत्तरे देते, नको असलेल्या श्रेणी नाकारते आणि प्रत्येक अयशस्वी लुकअपची नोंद ठेवते, जे सार्वजनिक DNS तुमच्यासाठी करू शकत नाही.
आपण GDPR अंतर्गत DNS क्वेरी लॉग कसे हाताळावेत?
DNS लॉग्सना वैयक्तिक डेटा म्हणून हाताळा, कारण ते IP पत्ते आणि त्या डिव्हाइसने भेट दिलेल्या डोमेन्सना जोडतात. एक निश्चित धारणा कालावधी (रिटेंशन कालावधी) सेट करा, तुमच्या नेटवर्क आणि सुरक्षितता टीमपुरतीच प्रवेशमर्यादित ठेवा आणि तुमच्या गोपनीयता सूचनेमध्ये (प्रायव्हसी नोटिस) याच्या उद्देशाची नोंद करा. Purple हे ISO 27001 प्रमाणित आणि GDPR चे सुसंगत आहे, आणि तुम्ही गेस्ट ट्रॅफिक यातून पाठवण्यापूर्वी तुमच्या DNS फिल्टर पुरवठादाराने समान प्रमाणपत्र दाखवले पाहिजे.
हे तैनात करण्यासाठी (डिप्लॉयमेंट) किती प्रयत्न करावे लागतात?
हा बदल स्वतःमध्ये खूप लहान आहे; बहुतेक वेळ चाचणी (टेस्टिंग) घेण्यात जातो. तुम्ही गेस्ट DHCP स्कोपमधील DNS सर्व्हर अपडेट करता, फिल्टरच्या अनुमती यादीत (अलो लिस्ट) पोर्टल डोमेन्स जोडता आणि वॉल गार्डन तपासता. वास्तविक गर्दीच्या वेळी, जसे की सकाळच्या घाईच्या वेळी किंवा हाफ-टाइम दरम्यान चाचणी घेण्याचे नियोजन करा, कारण शांत दुपारच्या वेळी त्रुटीस कारणीभूत ठरणाऱ्या ट्रॅफिकची गर्दी पुन्हा निर्माण होणार नाही.
Passpoint किंवा OpenRoaming ही त्रुटी दूर करेल का?
होय, ती वापरणाऱ्या डिव्हाइसेससाठी ही त्रुटी दूर होईल. Passpoint आणि OpenRoaming डिव्हाइसेसना कॅप्टिव्ह पोर्टलशिवाय सुरक्षितपणे कनेक्ट होऊ देतात, त्यामुळे तिथे अयशस्वी होण्यासाठी कोणतेही पोर्टल नसते. पहिल्यांदा भेट देणारे आणि Passpoint प्रोफाईल नसलेले डिव्हाइसेस अजूनही कॅप्टिव्ह पोर्टलचाच वापर करतात, त्यामुळे तुम्हाला अजूनही जलद DNS आणि पूर्ण वॉल गार्डनची गरज आहे. दोन्ही एकत्र चालवा: परत येणाऱ्या अभ्यागतांसाठी Passpoint आणि इतर सर्वांसाठी ट्यून केलेले पोर्टल.
महत्वाच्या व्याख्या
कॅप्टिव्ह पोर्टल
इंटरनेट ॲक्सेस देण्यापूर्वी गेस्ट नेटवर्क जे लॉगिन पेज सर्व्ह करते. RFC 8910 एक DHCP आणि IPv6 राउटर जाहिरात पर्याय परिभाषित करते जो डिव्हाइसला पोर्टलचा API पत्ता सांगतो, त्यामुळे त्याला अयशस्वी वेब विनंतीवरून पोर्टलचा अंदाज लावावा लागत नाही.
तुमचे अतिथी येथे अटी स्वीकारतात किंवा साइन इन करतात. जर पोर्टल कधीही उघडले नाही, तर ते ऑनलाइन जाऊ शकत नाहीत आणि समस्या फ्रंट डेस्क किंवा हेल्प पॉइंटवर येते.
कनेक्टिव्हिटी चेक
एक HTTP विनंती जी प्रत्येक ऑपरेटिंग सिस्टम नेटवर्कमध्ये सामील झाल्यानंतर ज्ञात होस्टनेमला पाठवते: iOS, iPadOS आणि macOS वर captive.apple.com, Android वर connectivitycheck.gstatic.com, आणि Windows 10 व 11 वर www.msftconnecttest.com. अपेक्षा केलेले पेज म्हणजे ऑनलाइन, लॉगिन पेज पोर्टल ट्रिगर करते आणि उत्तर न मिळणे म्हणजे "no internet".
हा चेक तुमच्या सपोर्ट टीमला दिसणाऱ्या प्रत्येक प्रकारचा इशारा तयार करतो. हे प्रथम DNS लुकअपवर अवलंबून असते, जिथे उच्च-घनतेची अपयश सुरू होते.
DNS (डोमेन नेम सिस्टम)
RFC 1035 मध्ये नमूद केलेला प्रोटोकॉल जो होस्टनेम्सचे IP पत्त्यांमध्ये निराकरण करतो. बहुतेक क्विअरीज UDP पोर्ट 53 वरून प्रवास करतात, ज्यामध्ये अंगभूत रीट्रांसमिशन नसते, त्यामुळे ड्रॉप झालेली क्विअरी डिव्हाइसच्या स्वतःच्या रीट्राई टायमरची वाट पाहते.
जेव्हा शेकडो डिव्हाइसेस एकाच वेळी जोडले जातात आणि रिझॉल्व्हर व्यस्त WAN लिंकवर असतो, तेव्हा लुकअप्स टाइम आउट होतात आणि पोर्टल कधीही उघडत नाही.
एंटरप्राइझ DNS फिल्टर
तुम्ही नियंत्रित करत असलेला रिझॉल्व्हर, जो गेस्ट नेटवर्कच्या जवळ ठेवला जातो, जो कॅशेमधून वारंवार होणाऱ्या लुकअप्सची उत्तरे देतो, गैरप्रकार किंवा ब्लॉक केलेल्या श्रेणींसाठीच्या क्विअरीज नाकारतो आणि डोमेन, वेळ व वारंवारतेनुसार प्रत्येक क्विअरीची नोंद ठेवतो.
हे तुमच्या गेस्ट DHCP स्कोपमधील दूरच्या ISP किंवा सार्वजनिक रिझॉल्व्हरची जागा घेते. ते वितरीत मालमत्तांसाठी क्लाउड-वितरित किंवा एका मोठ्या ठिकाणासाठी ऑन-साइट तैनात करा.
वॉल्ड गार्डन
कॅप्टिव्ह पोर्टल नेटवर्कवर प्रमाणीकरण करण्यापूर्वी डिव्हाइस ज्या डोमेन्सपर्यंत पोहोचू शकते त्यांची सूची. Cisco Meraki, HPE Aruba आणि Ruckus हे सर्व त्यांच्या कंट्रोलर कॉन्फिगरेशनमध्ये हा शब्द वापरतात.
तुमचे पोर्टल डोमेन्स किंवा मालमत्ता गहाळ असल्यास, पेज थांबते किंवा रिकामे दिसते. Purple चा प्रति-व्हेंडर सेटअप लेख अनुमती द्यायच्या अचूक डोमेन्सची सूची देतो.
DHCP पूल समाप्त होणे
अशी स्थिती जिथे Dynamic Host Configuration Protocol (RFC 2131) सर्व्हरच्या स्कोपमध्ये कोणतेही मोफत पत्ते शिल्लक नसतात, त्यामुळे नवीन डिव्हाइसेस स्वतःला 169.254.x.x लिंक-लोकल पत्ता असाइन करतात आणि कोणत्याही गोष्टीपर्यंत पोहोचू शकत नाहीत.
गेस्ट डिव्हाइसवरील 169.254.x.x पत्ता DNS नव्हे तर DHCP कडे निर्देश करतो. पूल मोठा करा किंवा लीजची वेळ कमी करा.
DNS over HTTPS (DoH) आणि DNS over TLS (DoT)
एनक्रिप्टेड DNS ट्रान्सपोर्ट्स: RFC 8484 मध्ये निर्दिष्ट केल्यानुसार DoH हे HTTPS मध्ये क्वेरी घेऊन जाते आणि RFC 7858 मध्ये निर्दिष्ट केल्यानुसार DoT हे TLS सत्रावरून घेऊन जाते. दोन्ही तुमच्या नेटवर्कच्या बाहेरील रिव्हॉल्व्हर्सकडे शोध पाठवतात.
या बाहेरील रिव्हॉल्व्हर्सना ब्लॉक करणारे वॉल्ड गार्डन लॉगिन करण्यापूर्वीचे शोध थांबवते. Android वर, अतिथीला प्रायव्हेट DNS ऑटोमॅटिकवर सेट करण्यास सांगा.
VLAN (व्हर्च्युअल LAN)
IEEE 802.1Q टॅगिंगद्वारे परिभाषित केलेले लॉजिकल नेटवर्क सेगमेंट, जे सामायिक केलेल्या स्विचिंग इन्फ्रास्ट्रक्चरवर अतिथी ट्रॅफिकला इतर नेटवर्कपासून वेगळे करते.
उत्तर न मिळालेल्या क्वेरी शोधण्यासाठी udp पोर्ट 53 वर फिल्टर केलेल्या अतिथी VLAN वरील पॅकेट्स कॅप्चर करा. सेगमेंटेशन अतिथी ट्रॅफिकला PCI DSS कार्डधारक डेटा एन्व्हायर्नमेंटच्या स्कोपपासून दूर ठेवते.
Passpoint (Hotspot 2.0) आणि OpenRoaming
Passpoint, ज्याला Hotspot 2.0 देखील म्हणतात, हे IEEE 802.11u नेटवर्क डिस्कव्हरी आणि IEEE 802.1X पोर्ट-आधारित प्रमाणीकरणावर आधारित आहे जेणेकरून प्रोफाइल असलेले डिव्हाइस कॅप्टिव्ह पोर्टलशिवाय सुरक्षितपणे कनेक्ट होते. OpenRoaming हे सहभागी नेटवर्कमध्ये विस्तारित करते.
प्रोफाइल असलेले परत येणारे भेट देणारे कधीही पोर्टलवर जात नाहीत, त्यामुळे त्यांच्यासाठी ही अपयशी पद्धत नाहीशी होते. पहिल्यांदा भेट देणाऱ्यांना अजूनही जलद DNS आणि संपूर्ण वॉल्ड गार्डनची आवश्यकता असते.
GDPR वैयक्तिक डेटा (DNS लॉग)
UK GDPR आणि EU GDPR अंतर्गत, IP पत्त्यासारख्या आयडेंटिफायरला ॲक्टिव्हिटीशी जोडणारी माहिती वैयक्तिक डेटा मानली जाते, ज्यासाठी परिभाषित हेतू, मर्यादित रिटेंशन आणि मर्यादित ॲक्सेस आवश्यक असतो.
DNS फिल्टर लॉग IP पत्त्यांना भेट दिलेल्या डोमेन्सशी जोडतात. रिटेंशन कालावधी सेट करा, तुमच्या नेटवर्क आणि सुरक्षा टीमसाठी ॲक्सेस मर्यादित करा आणि तुमच्या गोपनीयता सूचनेमध्ये हेतू नोंदवा.
सोडवलेली उदाहरणे
एका 200 खोल्यांच्या हॉटेलमध्ये सकाळी 7 ते 9 दरम्यान "no internet" बद्दल फ्रंट-डेस्क तक्रारी येतात. ॲक्सेस पॉइंट्स उत्तम सिग्नल आणि शिल्लक एअरटाइम दाखवतात, आणि गेस्ट DHCP एका व्यस्त लाईनद्वारे अनेक हॉप्सवरून ISP चे रिझॉल्व्हर पुरवते. IT व्यवस्थापकाने काय करावे? (आकडेवारी उदाहरणाखालoutput आहे.)
IT व्यवस्थापकाने गर्दीच्या वेळेत गेस्ट-नेटवर्क लॅपटॉपवरून nslookup चालवले आणि लुकअप्स पूर्णपणे अपयशी ठरताना पाहिले, ज्याने रेडिओ फॉल्टऐवजी DNS बॉटलनेकची पुष्टी केली. टीमने गेस्ट DHCP ला क्लाउड DNS फिल्टरकडे निर्देशित केले जेणेकरून वारंवार होणाऱ्या कनेक्टिव्हिटी-चेक लुकअप्सना कॅशेमधून उत्तरे दिली गेली. त्यांनी पोर्टल डोमेन्स वॉल्ड गार्डनमध्ये जोडले जेणेकरून साइन-इन करण्यापूर्वी लॉगिन पेज लोड होईल. त्यांनी सेगमेंटेशन राखण्यासाठी गेस्ट DNS मालमत्ता व्यवस्थापन नेटवर्कपासून वेगळे ठेवले. WiFi Analytics आणि डेस्क लॉगमध्ये मोजल्यानुसार, पीक वेळेत पोर्टल पूर्ण होण्याचे प्रमाण 81% वरून 97% पर्यंत वाढले आणि डेस्क तक्रारी एका सकाळी सुमारे 15 वरून दोनवर आल्या.
30,000 क्षमतेच्या स्टेडियममधील चाहते प्रत्येक हाफ-टाइमला "connected without internet" ची तक्रार करतात, तर प्रत्येक हाफचे पहिले दहा मिनिटे सुरळीत चालतात. सर्ज दरम्यान प्रतिसादाशिवाय DNS क्विअरीज गेस्ट VLAN वरील पॅकेट कॅप्चरमध्ये दिसतात. नेटवर्क आर्किटेक्टने कसा प्रतिसाद दिला पाहिजे? (आकडेवारी उदाहरणाखालoutput आहे.)
या पॅटर्नने गर्दीकडे निर्देश केला, म्हणून आर्किटेक्टने क्लाउड फॉलबॅकसह ऑन-साइट रिझॉल्व्हर तैनात केला. लुकअप्स ऑन-साइट ठेवल्याने सर्ज दरम्यान ते WAN वरून पूर्णपणे काढून टाकले गेले. टीमला क्लायंट-निहाय रेट लिमिट देखील आढळली आणि ती काढून टाकली गेली जी UDP पोर्ट 53 ला थ्रॉटल करत होती, ज्यामुळे हजारो डिव्हाइसेस एकाच वेळी जोडले गेल्यावर DNS ला प्रतिसाद मिळत नव्हता. त्यांनी गेस्ट DHCP स्कोप नवीन रिझॉल्व्हरवर हलवला. पाठपुरावा कॅप्चरमध्ये हाफ-टाइमला उत्तर न दिलेल्या DNS क्विअरीज 12% वरून 1% पेक्षा कमी झाल्याचे दिसून आले. अंतरालादरम्यान चाहत्यांच्या लॉगिनमध्ये मागील सामन्याच्या तुलनेत 40% वाढ झाली.
सराव प्रश्न
Q1. एका स्टेडियमच्या IT प्रमुखाच्या लक्षात येते की हाफ-टाईमदरम्यान, हजारो वापरकर्ते WiFi शी कनेक्ट होतात परंतु कॅप्टिव्ह पोर्टलपर्यंत पोहोचण्यात अयशस्वी ठरतात. कोर स्विच भारी UDP पॅकेट ड्रॉप दाखवतो. त्यांनी WAN बँडविड्थ 2Gbps वरून 5Gbps पर्यंत वाढवावी का?
टीप: कोणता प्रोटोकॉल ड्रॉप केला जात आहे आणि तो पेलोड बँडविड्थ किंवा कनेक्शन स्टेट लिमिटशी संबंधित आहे का याचा विचार करा.
नमुना उत्तर पहा
नाही. WAN बँडविड्थ वाढवून ही समस्या सुटणार नाही. UDP पॅकेट ड्रॉप्स हे दर्शवतात की फायरवॉल किंवा रिव्हॉल्व्हर समवर्ती DNS क्वेरींचे प्रमाण (स्टेट टेबल समाप्त होणे किंवा CPU मर्यादा) हाताळू शकत नाही. WAN बॉटलनेक पूर्णपणे बायपास करून, स्थानिकांवर या क्वेरी कॅश करण्यासाठी आणि प्रतिसाद देण्यासाठी एजवर उच्च-कार्यक्षमता स्थानिक DNS फिल्टर तैनात करणे हा योग्य दृष्टिकोन आहे.
Q2. तुम्ही नुकतेच एका हॉटेल गेस्ट नेटवर्कवर एंटरप्राइज DNS फिल्टर तैनात केले आहे. अतिथी आता सार्वजनिक वेबसाइट्स जलद रीझॉल्व्ह करू शकतात, परंतु ते प्रथम कनेक्ट होतात तेव्हा त्यांना हॉटेलच्या लॉगिन पेजवर रीडिरेक्ट केले जात नाही. सर्वाधिक संभाव्य कॉन्फिगरेशन एरर कोणती आहे?
टीप: लॉगिन पेजच्या डोमेन नावाचा विचार करा.
नमुना उत्तर पहा
सर्वात संभाव्य त्रुटी ही आहे की कॅप्टिव्ह पोर्टलचे स्वतःचे डोमेन DNS फिल्टरमध्ये स्पष्टपणे व्हाईटलिस्ट (पासथ्रू) केलेले नाही. फिल्टर पोर्टल URL च्या रिझोल्यूशनला ब्लॉक करत आहे किंवा उशीर करत आहे, ज्यामुळे रीडिरेक्शन पूर्ण होण्यापासून रोखले जात आहे.
Q3. सार्वजनिक क्षेत्रातील एका संस्थेला सुरक्षा धोरणांचे पालन करण्यासाठी सर्व अतिथी WiFi ट्रॅफिक 90 दिवसांसाठी लॉग करणे आवश्यक आहे. एंटरप्राइज DNS फिल्टर तैनात केल्याने या आवश्यकतेसाठी कशी मदत होते?
टीप: मानक फायरवॉलच्या तुलनेत DNS फिल्टर कोणत्या डेटावर प्रक्रिया करतो याचा विचार करा.
नमुना उत्तर पहा
एंटरप्राइझ DNS फिल्टर क्लायंट डिव्हाइसेसद्वारे केलेल्या सर्व DNS क्वेरी नेटिव्हली लॉग करतो. हे कोणत्या डोमेन्सची आणि कधी विनंती केली गेली होती याची एक स्पष्ट, शोधण्यायोग्य ऑडिट ट्रेल प्रदान करते, ज्यामुळे सर्व एनक्रिप्टेड HTTPS पेलोड ट्रॅफिकवर डीप पॅकेट तपासणी करण्याची आवश्यकता न पडता 90 दिवसांच्या लॉगिंगची आवश्यकता पूर्ण होते.
वारंवार विचारले जाणारे प्रश्न
Why does guest WiFi say connected but no internet?
The 'Connected, No Internet' status occurs when a client device associates with an access point and receives an IP address, but its operating system detection probe fails to reach the internet. On guest WiFi networks, this is most commonly caused by DNS query timeouts on captive portal detection domains (such as captive.apple.com or connectivitycheck.gstatic.com), DHCP lease scope exhaustion, or firewalls blocking pre-authentication DNS traffic.
How do captive portal detection probes work on guest WiFi across iOS, Android, and Windows?
When connecting to an open or guest WiFi SSID, modern operating systems immediately transmit plaintext HTTP probe requests to vendor test URLs (iOS uses captive.apple.com/hotspot-detect.html, Android queries connectivitycheck.gstatic.com/generate_204, and Windows tests msftconnecttest.com/connecttest.txt). If the network returns an HTTP 200/204, the OS marks the connection as having internet. If it receives an HTTP 302 redirect, it launches the captive portal browser. If the initial DNS query for the probe domain times out, the OS reports 'Connected, No Internet' and drops the link.
How do DNS timeouts trigger guest WiFi connection drops?
In high-density environments, hundreds of devices query upstream DNS resolvers simultaneously over UDP port 53. If the local guest WiFi network forwards raw queries directly to rate-limited ISP resolvers without caching, response latency spikes above 2,000ms. Mobile devices enforce strict 2- to 5-second probe timeouts. Once that threshold is exceeded, the device assumes the network is broken and abandons the connection before the splash page can load.
What walled garden domains must be allowed before guest WiFi captive portal login?
Pre-authentication access control lists (walled gardens) on guest WiFi networks must permit outbound UDP and TCP port 53 to your designated DNS resolvers, DHCP transactions (UDP 67/68), and OS detection probes (captive.apple.com, connectivitycheck.gstatic.com, msftconnecttest.com). If using external captive portal hosting, CDN styling, or social login, you must also allow your portal domain (*.purple.ai), Google Fonts (fonts.googleapis.com), and OAuth endpoints.
How does DHCP pool exhaustion cause connected without internet errors on guest WiFi?
When venues configure long DHCP lease durations (such as 24 hours) on guest WiFi in environments with rapid visitor turnover, the pool of available IP addresses quickly runs out. New arrivals may associate with the access point via 802.11 beacons, but fail to receive a valid DHCPOFFER or default gateway, receiving a self-assigned 169.254.x.x APIPA address instead. Shortening lease times to 30 to 60 minutes and configuring dynamic VLAN pooling prevents scope starvation.
How does Purple prevent captive portal and DNS timeout failures on guest WiFi?
Purple acts as a resilient, hardware-agnostic guest WiFi management platform across Cisco Meraki, HPE Aruba, Ruckus, Ubiquiti UniFi, and Fortinet architectures. By optimizing captive portal redirection flows, automating walled garden rules, and integrating with high-speed Anycast DNS, Purple ensures detection probes succeed instantly, onboarding visitors in under 3 seconds without connection drops.
स्रोत
- RFC 1035: Domain names, implementation and specification
- RFC 8484: DNS queries over HTTPS (DoH)
- RFC 7858: DNS over Transport Layer Security (DoT)
- RFC 8910: Captive-portal identification in DHCP and Router Advertisements
- RFC 2131: Dynamic Host Configuration Protocol
- PCI Security Standards Council: PCI DSS
- Information Commissioner's Office: UK GDPR guidance
या मालिकेमध्ये पुढे वाचा
संतोषजनक नसलेल्या WiFi कामगिरीचे निदान करण्यासाठी पॅकेट कॅप्चर (PCAP) चा वापर करणे
हे तांत्रिक संदर्भ मार्गदर्शक IT व्यवस्थापक, नेटवर्क आर्किटेक्ट आणि वेन्यू ऑपरेशन्स डायरेक्टर्सना Packet Capture (PCAP) विश्लेषणाचा वापर करून संथ असणाऱ्या एंटरप्राइझ WiFi कामगिरीचे अचूक निदान आणि निराकरण करण्यासाठी एक संरचित, पॅकेट - पातळीवरील कार्यपद्धती प्रदान करते. री-ट्रान्समिशन दर, एअरटाइम वापर आणि फिजिकल लेयर मेटाडेटा यासह कच्च्या 802.11 फ्रेम्सचे विश्लेषण करून, टीम्स RF - लेयरमधील अडथळे वायर्ड किंवा ॲप्लिकेशन समस्यांपासून अचूकपणे वेगळे करू शकतात. हॉटेल्स, रिटेल साखळ्या, स्टेडियम आणि कॉन्फरन्स सेंटर्ससह अति-गर्दीच्या ठिकाणांवर लागू होणारे, हे मार्गदर्शक नेटवर्क क्षमता पुन्हा मिळवण्यासाठी आणि अतिथींच्या अनुभवाचे रक्षण करण्यासाठी व्यावहारिक निदान वर्कफ्लो, वास्तविक-जगातील केस स्टडीज आणि कॉन्फिगरेशन सुधारणा पायऱ्या प्रदान करते.
तुमचे Stadium WiFi का ठप्प होते (आणि ते कसे दुरुस्त करावे)
हे अधिकृत तांत्रिक मार्गदर्शक stadium WiFi मधील गर्दीच्या मूळ कारणाचे - ५०,००० डिव्हाइसेसद्वारे प्रोग्रामॅटिक जाहिराती आणि टेलिमेट्री लोड करताना होणाऱ्या एकाच वेळच्या बॅकग्राउंड चॅटरचे - विश्लेषण करते आणि मुख्य निवारण धोरण म्हणून एज DNS फिल्टरिंग तैनात करण्यासाठी एक तपशीलवार आर्किटेक्चरल ब्लूप्रिंट प्रदान करते. IT Directors, CTOs, आणि Network Architects यांच्यासाठी डिझाइन केलेले, हे वेन्यू ऑपरेटर्सना बँडविड्थ परत मिळवून देण्यासाठी आणि मोठ्या प्रमाणावर उच्च-कार्यक्षमता कनेक्टिव्हिटी प्रदान करण्यासाठी कृतीयोग्य अंमलबजावणी मार्गदर्शन, वास्तविक-जगातील केस स्टडीज आणि मोजण्यायोग्य ROI फ्रेमवर्क प्रदान करते.
आपला Guest WiFi इतका संथ का आहे? नेटवर्क कंजेशनचे निदान
हे मार्गदर्शक guest WiFi कंजेशनच्या अदृश्य कारणांचे निदान करते - बॅकग्राउंड टेलिमेट्री, प्रोग्रामॅटिक जाहिरात नेटवर्क आणि ऑटोमेटेड OS अपडेट्स - जे सामूहिकपणे अतिथीने ब्राउझर उघडण्यापूर्वीच सार्वजनिक WiFi बँडविड्थच्या 40% पर्यंत वापरतात. हे DNS फिल्टरिंग आणि QoS पॉलिसींसाठी एक टप्प्याटप्प्याने, वेंडर-तटस्थ अंमलबजावणी फ्रेमवर्क प्रदान करते जे ती बँडविड्थ पुन्हा मिळवून देते, अतिथींचा अनुभव सुधारते आणि मोजता येण्याजोगा ROI देते. हॉस्पिटॅलिटी, रिटेल, इव्हेंट्स आणि सार्वजनिक-क्षेत्रातील वातावरणातील IT संचालक आणि ऑपरेशन्स मॅनेजर्ससाठी हे उद्दिष्टित आहे.
तुमच्या विशिष्ट सेटअपबद्दल काही प्रश्न आहेत का?
आमची टीम ८०,००० हून अधिक वेन्यूजमधील वेन्यू ऑपरेटर्स, IT मॅनेजर्स आणि नेटवर्क इंजिनिअर्ससोबत काम करते. २० मिनिटांचा कॉल बुक करा आणि तुमच्यासारख्या इतरांनी ही समस्या कशी सोडवली हे आम्ही तुम्हाला दाखवू.